Cannot play on-demand recorded calls

Symptoms

On extensions where the on-demand recording mode is enabled, the calls can be seen in the on-demand recording buffer, but when selecting a call to be saved as recorded call, I see the call under search, however the calls is still has no play button. I can not listen to the call.

Root cause

In most cases the root cause is that the Verba storage service is either not running or the on-demand feature is not enabled in it.

Resolution

Follow these steps:

  1. Login as administrator
  2. Select in the Administration / Verba servers menu, select your media respository or combo server depending on your deployment
  3. Verify on the Service Control tab that the Verba Storage Management Service is running
  4. Select the Change configuration tab
  5. Expand Storage management configuration / On-demand recording settings
  6. Enable "On-demand Calls Administration", and set ondemand buffer size according to your needs
  7. Save the settings and don't forget executing pending configuration changes through the orange strip that says "There are tasks to be executed..."

The storage cycle runs approximately every minute and transfers the on-demand calls to their final media storage path. When this happens you will be able to play the kept calls. In worst case you will have to wait 1 minute for a call, typically it is much faster.

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