Caller and called number identical and names are missing

Symptoms

These symptoms are specific to Cisco central recording:

  • call detail information is not presented properly
  • both caller and called parties are the same on some or all recordings
  • caller and called information field (e.g. names) are not filled in
  • user information is missing
The above events typically happen at the same time.

Root cause

This problem is most likely caused by a a failure or misconfiguration of the JTAPI connection between the recorder and Cisco UCM. The JTAPI connection is necessary to enrich the call details collected by our Cisco central recorder service.

When JTAPI is down the recording system still writes all available information into the database as a fallback solution. This way you will still find calls on the phone, but
  • called number information is not available,
  • caller and called names are not available,
  • you can not see if the call was incoming or outgoing.

Resolution

Please verify that the JTAPI related configuration is properly done:

  1. Verify that the Verba Central Recording Database Service is activated and is running - See Configuring the Verba Central Cisco Recorder
  2. Verify that the recorded phone device is added to JTAPI user - See Adding a new extension for recording in Cisco UCM
  3. Verify that your JTAPI exists and is added to proper groups - See Creating an application user for the JTAPI connection
  4. Verify that the UCM address and JTAPI credentials are properly configured in Verba - See Configuring the Verba Central Cisco Recorder
  5. Restart the CTI Service in Cisco UCM - in certain cases this might solve JTAPI issues

If none of the above steps help you resolve your problem, please open a support ticket.

Note! To avoid longer service outages, you should always configure the built-in Verba System Monitoring: http://kb.verba.com/display/docs/Automated+monitoring+functions

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